• Chat_sec.src

    From MysticOne@VERT to All on Sun Nov 17 16:06:00 2002

    Okay, here's the getcmd line, and the lines surrounding the area I'm talking about. I don't want to paste the entire thing here ... but, well, if you guys want me to, I can.

    -+-

    # chat_sec.src

    # Chat Section for any/all Synchronet command shells

    # Requires v3.00g or later

    !include sbbsdefs.inc

    compare_ars rest C
    if_true
    print "\r\nYou can't chat.\r\n"
    return
    end_if

    # Set return point for main menu commands (via end_cmd)
    cmd_home

    # Display TEXT\MENU\CHAT.* if not in expert mode
    compare_user_misc UM_EXPERT
    if_false
    menu_chat
    end_if

    # Update node status
    node_action node_chat
    async
    print "\r\n\1_\1y\1hChat: \1n"
    getcmd "ACDFIJPQSTU?\r"
    cmdkey 'S'
    TOGGLE_USER_CHAT CHAT_SPLITP
    printf "\1n\r\nPrivate split-screen chat is now: \1h"
    COMPARE_USER_CHAT CHAT_SPLITP
    if_true
    print "ON\1n"
    else
    print "OFF\1n"
    end_if
    crlf
    end_cmd

    cmdkey 'A'
    crlf
    toggle_user_chat CHAT_NOACT
    toggle_node_misc NODE_AOFF
    nodelist_users
    end_cmd

    (and so on and so forth until we reach close to the things I changed)

    cmdkey 'T'
    page_guru
    end_cmd

    cmdkey 'U'
    exec_xtern "syncreg" (this has also been exec_xtern syncreg)
    end_cmd ( and SYNCREG ... no change)

    cmdkey '?'
    compare_user_misc UM_EXPERT
    if_true
    menu "chat"
    end_if
    end_cmd

    cmdpop

    return

    ----

    Well, that should be enough. I'm recompiling it each time after I've changed it, and it doesn't give me any sort of errors or anything. Just compiles all nice and happy, and then doesn't work. Thanks! :)

    -- MysticOne












    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>
  • From Merlin@VERT to MysticOne on Sun Nov 17 19:44:00 2002
    Re: Chat_sec.src
    By: MysticOne to All on Sun Nov 17 2002 04:06 pm


    cmdkey 'U'
    exec_xtern "syncreg" (this has also been exec_xtern syncreg)
    end_cmd ( and SYNCREG ... no change)

    The command I use here is exec_xtrn (not xtErn)

    That could be the problem ---------------------------------------------------------------------------
    Merlin - Sysop of CarSo BBs - telnet://carso.darktech.org ---------------------------------------------------------------------------


    ---
    Synchronet CarSo BBs Beverley, UK telnet://carso.darktech.org
  • From Digital Man@VERT to MysticOne on Sun Nov 17 17:31:19 2002
    Re: Chat_sec.src
    By: MysticOne to All on Sun Nov 17 2002 04:06 pm

    (and so on and so forth until we reach close to the things I changed)

    cmdkey 'T'
    page_guru
    end_cmd

    cmdkey 'U'
    exec_xtern "syncreg" (this has also been exec_xtern syncreg)
    end_cmd ( and SYNCREG ... no change)

    Well, that should be enough. I'm recompiling it each time after I've change it, and it doesn't give me any sort of errors or anything. Just compiles al nice and happy, and then doesn't work. Thanks! :)

    It should give you a complier error since "exec_xtrn" is mispelled.

    digital man
    ---
    Synchronet Vertrauen Home of Synchronet telnet://vert.synchro.net
  • From Nemesis@VERT to Digital Man on Sun Nov 17 20:11:00 2002
    Re: Chat_sec.src
    By: Digital Man to MysticOne on Sun Nov 17 2002 17:31:00

    It should give you a complier error since "exec_xtrn" is mispelled.
    ^^^^^^^^

    Resisting...urge...to...make smartass comment.... ;)


    <!-- Ryan Underwood, sysop: The IceForge -->


    ---
    Synchronet The IceForge * SBBS/Linux: forge.icequake.net * Missouri, USA
  • From MysticOne@VERT to Nemesis on Mon Nov 18 15:11:00 2002
    Re: Chat_sec.src
    By: Nemesis to Digital Man on Sun Nov 17 2002 08:11 pm

    Re: Chat_sec.src
    By: Digital Man to MysticOne on Sun Nov 17 2002 17:31:00

    It should give you a complier error since "exec_xtrn" is mispelled.
    ^^^^^^^^

    Resisting...urge...to...make smartass comment.... ;)


    <!-- Ryan Underwood, sysop: The IceForge -->



    Hahahaha! Sorry, that was funny. :) But anyway, no, it is NOT misspelled within the file. I had a followup message to Merlin that stated that. The actual source file does say exec_xtrn syncreg, and there are no compiler errors whatsoever when I recompile it.

    -- MysticOne

    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>
  • From Digital Man@VERT to MysticOne on Mon Nov 18 15:33:59 2002
    Re: Chat_sec.src
    By: MysticOne to Nemesis on Mon Nov 18 2002 03:11 pm

    Hahahaha! Sorry, that was funny. :) But anyway, no, it is NOT misspelled within the file. I had a followup message to Merlin that stated that. The actual source file does say exec_xtrn syncreg, and there are no compiler err whatsoever when I recompile it.

    So you have tried adding print statements or anything to help debug the problem?

    digital man
    ---
    Synchronet Vertrauen Home of Synchronet telnet://vert.synchro.net
  • From MysticOne@VERT to Digital Man on Tue Nov 19 20:19:00 2002
    Re: Chat_sec.src
    By: Digital Man to MysticOne on Mon Nov 18 2002 03:33 pm

    Re: Chat_sec.src
    By: MysticOne to Nemesis on Mon Nov 18 2002 03:11 pm

    Hahahaha! Sorry, that was funny. :) But anyway, no, it is NOT misspell within the file. I had a followup message to Merlin that stated that. T actual source file does say exec_xtrn syncreg, and there are no compiler whatsoever when I recompile it.

    So you have tried adding print statements or anything to help debug the problem?

    digital man


    Yep, it still doesn't do anything. I can hit U (the key I'm trying to setup as a cmdkey) all day long... absolutely nothing, no response. And as I said before, it is listed in the getcmd list, and there are no errors when compiling.

    -- MysticOne

    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>
  • From Finnigann@VERT to MysticOne on Wed Nov 20 13:17:00 2002
    With interpidation and the MAGIC of QWK Mail MysticOne wrote to Digital Man
    <=-

    Re: Chat_sec.src
    By: Digital Man to MysticOne on Mon Nov 18 2002 03:33 pm

    Re: Chat_sec.src
    By: MysticOne to Nemesis on Mon Nov 18 2002 03:11 pm

    Hahahaha! Sorry, that was funny. :) But anyway, no, it is NOT misspell within the file. I had a followup message to Merlin that stated that. T actual source file does say exec_xtrn syncreg, and there are no compiler whatsoever when I recompile it.

    So you have tried adding print statements or anything to help debug the problem?

    digital man


    Yep, it still doesn't do anything. I can hit U (the key I'm trying to setup as a cmdkey) all day long... absolutely nothing, no response.
    And as I said before, it is listed in the getcmd list, and there are no errors when compiling.

    You did recompile of course...


    ________________________________________________________________
    James King KC8UGV | ftp://bnb.dtdns.net\TV-NET.ZIP
    Sysop - Bits-N-Bytes BBS | Get TV-NET here! Honk!
    Coldwater, MI 49036 | http://www.synchro.net/sbbslist.html
    ----------------------------------------------------------------

    ... I know my own mind, and it's around here someplace ...
    --- MultiMail/MS-DOS v0.43
    Synchronet Bits-N-Bytes BBS One Hellofa BBS telnet://bnb.dtdns.net
  • From Tracker1@VERT to All on Wed Nov 20 18:11:00 2002
    MysticOne wrote:

    Yep, it still doesn't do anything. I can hit U (the key I'm trying to setup as
    a cmdkey) all day long... absolutely nothing, no response. And as I said before, it is listed in the getcmd list, and there are no errors when compiling.

    if you email me the source tracker1(at)s3.bbs.us (sorry, theroughnecks
    is down because of a T3 outtage :( )

    I will look at it when I get a chance tomorrow...

    --
    -----------------------------------------------------------------------
    Michael J. Ryan | ICQ: 4935386
    tracker1(at)theroughnecks(dot)net | AIM/AOL: azTracker1
    Roughneck BBS: | Yahoo: azTracker1
    http://www.theroughnecks.net | MSN: (email address)
    telnet://theroughnecks.net | Trillian: www.trillian.cc

    ---
    Synchronet s3.bbs.us - Synchronet 3 Interface Designs
  • From MysticOne@VERT to Finnigann on Wed Nov 20 23:20:00 2002
    Re: Re: Chat_sec.src
    By: Finnigann to MysticOne on Wed Nov 20 2002 01:17 pm


    :) Yes, I did recompile. I'm not quite sure what it is. When I get a chance I'm going to send the source into DM and see if he can figure it out. But, haven't had the time yet to do it. Then, if it works for him, I'll just accept the fact that Baja hates me :)

    -- MysticOne

    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>
  • From Digital Man@VERT to MysticOne on Mon Nov 25 17:59:50 2002
    Re: Chat_sec.src
    By: MysticOne to Digital Man on Tue Nov 19 2002 08:19 pm

    Hahahaha! Sorry, that was funny. :) But anyway, no, it is NOT missp within the file. I had a followup message to Merlin that stated that. actual source file does say exec_xtrn syncreg, and there are no compil whatsoever when I recompile it.

    So you have tried adding print statements or anything to help debug the problem?

    digital man


    Yep, it still doesn't do anything. I can hit U (the key I'm trying to setup a cmdkey) all day long... absolutely nothing, no response. And as I said before, it is listed in the getcmd list, and there are no errors when compiling.

    Then it sounds like CHAT_SEC.BIN isn't being executed at all. Have you tried executing it with the ;EXEC sysop command?

    digital man
    ---
    Synchronet Vertrauen Home of Synchronet telnet://vert.synchro.net
  • From MysticOne@VERT to Digital Man on Tue Nov 26 08:10:00 2002
    Re: Chat_sec.src
    By: Digital Man to MysticOne on Mon Nov 25 2002 05:59 pm

    Yep, it still doesn't do anything. I can hit U (the key I'm trying to se a cmdkey) all day long... absolutely nothing, no response. And as I said before, it is listed in the getcmd list, and there are no errors when compiling.

    Then it sounds like CHAT_SEC.BIN isn't being executed at all. Have you tried executing it with the ;EXEC sysop command?

    digital man

    Whoa! If I execute it with the SysOp commands (chat_sec.bin), I can run the user registry option! Now, why in the world would it do that? I can go to the chat menu and all, and get into multinode chat and all that jazz. But the User registry option I've added doesn't work from there. But it DID work when I executed the chat_sec.bin module manually!

    -- MysticOne

    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>
  • From Tracker1@VERT to All on Tue Nov 26 11:40:00 2002
    MysticOne wrote:
    Re: Chat_sec.src
    By: Digital Man to MysticOne on Mon Nov 25 2002 05:59 pm

    Yep, it still doesn't do anything. I can hit U (the key I'm trying to se
    a cmdkey) all day long... absolutely nothing, no response. And as I said
    before, it is listed in the getcmd list, and there are no errors when compiling.

    Then it sounds like CHAT_SEC.BIN isn't being executed at all. Have you tried
    executing it with the ;EXEC sysop command?

    Whoa! If I execute it with the SysOp commands (chat_sec.bin), I can run the user registry option! Now, why in the world would it do that? I can go to the
    chat menu and all, and get into multinode chat and all that jazz. But the User
    registry option I've added doesn't work from there. But it DID work when I executed the chat_sec.bin module manually!

    sounds like your shell is running the old internal chat menu, instead of
    exec *chat_sec

    --
    -----------------------------------------------------------------------
    Michael J. Ryan | ICQ: 4935386
    tracker1(at)theroughnecks(dot)net | AIM/AOL: azTracker1
    Roughneck BBS: | Yahoo: azTracker1
    http://www.theroughnecks.net | MSN: (email address)
    telnet://theroughnecks.net | Trillian: www.trillian.cc

    ---
    Synchronet s3.bbs.us - Synchronet 3 Interface Designs
  • From Digital Man@VERT to MysticOne on Tue Nov 26 11:10:13 2002
    Re: Chat_sec.src
    By: MysticOne to Digital Man on Tue Nov 26 2002 08:10 am

    Yep, it still doesn't do anything. I can hit U (the key I'm trying to a cmdkey) all day long... absolutely nothing, no response. And as I s before, it is listed in the getcmd list, and there are no errors when compiling.

    Then it sounds like CHAT_SEC.BIN isn't being executed at all. Have you tr executing it with the ;EXEC sysop command?

    Whoa! If I execute it with the SysOp commands (chat_sec.bin), I can run the user registry option! Now, why in the world would it do that? I can go to chat menu and all, and get into multinode chat and all that jazz. But the U registry option I've added doesn't work from there. But it DID work when I executed the chat_sec.bin module manually!

    Which command shell are you using? It sounds like you're not using the version that came with the v3.10 beta which includes the following change:
    from:
    chat_section
    to:
    exec_bin chat_sec

    digital man
    ---
    Synchronet Vertrauen Home of Synchronet telnet://vert.synchro.net
  • From MysticOne@VERT to Digital Man on Tue Nov 26 18:28:00 2002
    Re: Chat_sec.src
    By: Digital Man to MysticOne on Tue Nov 26 2002 11:10 am


    Okay, now the mystery has been solved. I'm using a modified version of the Renegade shell (I changed the menus, some of the commands, etc.,) because I didn't really like the all-in-one approach to the classic menus. Well, for some reason, the Renegade shell still points to chat_section, rather than the exec_bin chat_sec that the classic has. So *that* was the problem ... the cmdkey was going in just fine, but since I couldn't load up that module, it didn't ever get a chance to actually do anything with it. :) Thanks for your help, and everyone else's help too :)

    -- MysticOne

    ---
    Synchronet ~-._.-= The Realm of Dreams =-._.-~ <bbs.mysticone.com>