• !include sbbsdefs.inc

    From Fang-Castro@VERT/FTPBBS to All on Wed Aug 19 00:15:58 2020
    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    Edge of Oblivion BBS no longer exists otherwise I would've tried there first.

    Is there a comparable line I could put in the .src file so baja doesn't give a compile error? I'm figuring this isn't going to be the only problem I run into. What is/was SBBSDEFS.INC?

    These mods all look like there from 2004-2005. I don't know anything about programming baja/javascript =/ It's one reason I use Synchronet; maybe I'll learn.

    --thanks for any advice

    [fLEE.tHE.pLANET.bBS][916.pRI.vATE]

    ---
    Synchronet flee the planet bbs
  • From Digital Man@VERT to Fang-Castro on Wed Aug 19 12:32:05 2020
    Re: !include sbbsdefs.inc
    By: Fang-Castro to All on Wed Aug 19 2020 12:15 am

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    What is the error?

    Edge of Oblivion BBS no longer exists otherwise I would've tried there first.

    MRO is still around.

    Is there a comparable line I could put in the .src file so baja doesn't give a compile error? I'm figuring this isn't going to be the only problem I run into. What is/was SBBSDEFS.INC?

    Synchronet BBS definitions. It still exists and you should have it in your "exec" directory.

    These mods all look like there from 2004-2005. I don't know anything about programming baja/javascript =/ It's one reason I use Synchronet; maybe I'll learn.

    Cool. Sounds like maybe you need to specify the "-i /path/to/exec" argument on your baja command-line so that it can find the sbbsdefs.inc file.

    Or, if it's just a matter of case (e.g. SBBSDEFS.INC vs sbbsdefs.inc), create a symlink from SBBSDEFS.INC to sbbsdefs.inc (on *nix). If on Windows, then that would not be the problem.

    digital man

    Synchronet "Real Fact" #68:
    Robert D. Bouman, the author of SyncEdit, died in the mid to late 1990's. Norco, CA WX: 98.2F, 40.0% humidity, 6 mph NE wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Fang-Castro@VERT/FTPBBS to Digital Man on Wed Aug 19 16:43:55 2020
    Re: !include sbbsdefs.inc
    By: Digital Man to Fang-Castro on Wed Aug 19 2020 12:32 pm

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    What is the error?

    something like unable to include sbbsdefs.inc. i saved your reply, i think the rest of what you instructed me on will be helpful. thanks!

    [fLEE.tHE.pLANET.bBS][916.pRI.vATE]

    ---
    Synchronet flee the planet bbs
  • From Digital Man@VERT to Fang-Castro on Wed Aug 19 17:34:14 2020
    Re: !include sbbsdefs.inc
    By: Fang-Castro to Digital Man on Wed Aug 19 2020 04:43 pm

    Re: !include sbbsdefs.inc
    By: Digital Man to Fang-Castro on Wed Aug 19 2020 12:32 pm

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    What is the error?

    something like unable to include sbbsdefs.inc. i saved your reply, i think the rest of what you instructed me on will be helpful. thanks!

    I see you're running on Linux, so it's likely just the capitalization of the sbbsdefs.inc filename that's the issue. A symlink would work-around that. Or you could fix the .src file(s).

    digital man

    Sling Blade quote #16:
    Karl Childers (to Doyle, re: lawn mower blade): I aim to kill you with it. Mmm. Norco, CA WX: 91.6F, 42.0% humidity, 10 mph NE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Fang-Castro@VERT/FTPBBS to Digital Man on Wed Aug 19 18:45:42 2020
    Re: !include sbbsdefs.inc
    By: Digital Man to Fang-Castro on Wed Aug 19 2020 05:34 pm

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.
    What is the error?
    something like unable to include sbbsdefs.inc. i saved your reply, i

    I see you're running on Linux, so it's likely just the capitalization of the sbbsdefs.inc filename that's the issue. A symlink would work-around that. Or you could fix the .src file(s).

    OMG... that's probably it. Maybe if I wasn't having so much fun messing with muh BBS I'd get some sleep and stop making stupid mistakes =)

    [fLEE.tHE.pLANET.bBS][916.pRI.vATE]

    ---
    Synchronet flee the planet bbs
  • From MRO@VERT/BBSESINF to Fang-Castro on Sat Aug 22 03:36:46 2020
    Re: !include sbbsdefs.inc
    By: Fang-Castro to All on Wed Aug 19 2020 12:15 am

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    Edge of Oblivion BBS no longer exists otherwise I would've tried there first.

    Is there a comparable line I could put in the .src file so baja doesn't give a compile error? I'm figuring this isn't going to be the only problem I run into. What is/was SBBSDEFS.INC?

    These mods all look like there from 2004-2005. I don't know anything about programming baja/javascript =/ It's one reason I use Synchronet; maybe I'll learn.



    that's my bbs and it's still up.
    just it shouldnt give an error with that msg.

    you're not giving enough information. what is the mod and the version and what is your compile error.

    you probably are compiling it in a directory there those files are not located. ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From MRO@VERT/BBSESINF to Fang-Castro on Sat Aug 22 03:39:03 2020
    Re: !include sbbsdefs.inc
    By: Fang-Castro to Digital Man on Wed Aug 19 2020 06:45 pm

    OMG... that's probably it. Maybe if I wasn't having so much fun messing with muh BBS I'd get some sleep and stop making stupid mistakes =)


    yeah that's probably it.

    next time when reporting a bug:

    + what version of synchronet and what os
    + what is the mod name and version and where can we download it
    + what is the exact error [screenshots are good]
    + what are you doing that causes this error.

    my bbs is still up. i should probably delete all my mods
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From Fang-Castro@VERT/FTPBBS to MRO on Mon Aug 24 20:23:21 2020
    Re: !include sbbsdefs.inc
    By: MRO to Fang-Castro on Sat Aug 22 2020 03:36 am

    I picked up a pack of all of -oblivious-'s mods for Synchronet and they all have "!include sbbsdefs.inc" in the .src files so I get a compile error.

    Edge of Oblivion BBS no longer exists otherwise I would've tried there first.

    that's my bbs and it's still up.
    just it shouldnt give an error with that msg.

    Digital Man straighten me but thanks for the help.

    you're not giving enough information. what is the mod and the version and

    I'm using your oneliners mod. =p~ I changed it around a little bit. I have a file called AFTER.ZIP I downloaded with all your mods in it. Gonna play around with all of 'em. Thanks for making these!

    [fLEE.tHE.pLANET.bBS][916.pRI.vATE]

    ---
    Synchronet flee the planet bbs
  • From Fang-Castro@VERT/FTPBBS to MRO on Mon Aug 24 20:24:08 2020
    Re: !include sbbsdefs.inc
    By: MRO to Fang-Castro on Sat Aug 22 2020 03:39 am

    next time when reporting a bug:

    + what version of synchronet and what os
    + what is the mod name and version and where can we download it
    + what is the exact error [screenshots are good]
    + what are you doing that causes this error.

    good point.

    my bbs is still up. i should probably delete all my mods

    nooooooooo!

    [fLEE.tHE.pLANET.bBS][916.pRI.vATE]

    ---
    Synchronet flee the planet bbs