• Static IPs on Debian 9 (Stretch)

    From Vk3jed@VERT/FREEWAY to All on Sun May 26 20:06:31 2019
    Hi,

    I have a Debian 9 netbook here. Because I have an unusual setup here, I need to use manual IP address configuration. I used the default network manager to setup the static IPv4 and IPv6 addresses on the wifi interface. When I start the system, all works fine, and the correct IPs and routing information as I setup via the GUI are in place.

    However, when there's a network upset (most probably due to the router rebooting, or some other wifi disturbance), the static IPs are gone and are replaced by a DHCP assigned IPv4 address. This causes a number of issues, breaking connectivity with the BBS that is running on the system.

    In the good old days, I'd have done a total manual configuration, and this would have stuck, but I decided to use the tools provided for 2 reasons:

    1. To work with the new ways of doing things, rather than figting the system.

    2. To simplify the configuration of the wifi (i.e. not having to mess around with wpa-supplicant directly).

    Anyone seen this behaviour? And better still, anyone have a solution?

    ---
    Synchronet Freeway BBS, Bendigo Australia. freeway.apana.org.au
  • From Dan Clough@VERT/PALANT to Vk3jed on Sun May 26 08:22:00 2019
    Vk3jed wrote to All <=-

    I have a Debian 9 netbook here. Because I have an unusual setup
    here, I need to use manual IP address configuration. I used the
    default network manager to setup the static IPv4 and IPv6
    addresses on the wifi interface. When I start the system, all
    works fine, and the correct IPs and routing information as I
    setup via the GUI are in place.

    However, when there's a network upset (most probably due to the
    router rebooting, or some other wifi disturbance), the static IPs
    are gone and are replaced by a DHCP assigned IPv4 address. This
    causes a number of issues, breaking connectivity with the BBS
    that is running on the system.

    In the good old days, I'd have done a total manual configuration,
    and this would have stuck, but I decided to use the tools
    provided for 2 reasons:

    1. To work with the new ways of doing things, rather than
    figting the system.

    2. To simplify the configuration of the wifi (i.e. not having to
    mess around with wpa-supplicant directly).

    Anyone seen this behaviour? And better still, anyone have a
    solution?

    I'm not a Debian expert, but I do use a couple of Raspberry Pi's
    running Raspbian (which is basically Debian Stretch). What has
    always worked fine for me is to edit /etc/dhcpcd.conf and just add
    the following block on to the end of the file:

    interface wlan0
    static ip_address=192.168.1.99/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1

    That's it. Obviously adjust IP's and maybe the interface name to
    suit.

    ... Internal Error: The system has been taken over by sheep at line 19960
    --- MultiMail/Linux v0.52
    Synchronet Palantir BBS * palantirbbs.ddns.net * Pensacola, FL
  • From Vk3jed@VERT/FREEWAY to Dan Clough on Mon May 27 08:48:00 2019
    On 05-26-19 08:22, Dan Clough wrote to Vk3jed <=-

    I'm not a Debian expert, but I do use a couple of Raspberry Pi's
    running Raspbian (which is basically Debian Stretch). What has
    always worked fine for me is to edit /etc/dhcpcd.conf and just add
    the following block on to the end of the file:

    interface wlan0
    static ip_address=192.168.1.99/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.1.1

    That's it. Obviously adjust IP's and maybe the interface name to
    suit.

    Hmm, and IPv6 as well? Spose all I can do is give it a try. :)

    Just had a look. Looks like my system is using dhclient. I've added the equivalent options (for IPv4) to dhclient.conf.


    ... We are the very model of cartoon individuals.
    --- MultiMail/Win32 v0.49
    Synchronet Freeway BBS, Bendigo Australia. freeway.apana.org.au